PEAR Forum :: PHP Extension and Application Repository

PEAR Forum Forum Index
 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
Trying to upgrade

 
Post new topic   Reply to topic    PEAR Forum Forum Index -> PEAR
View previous topic :: View next topic  
Author Message
rklockner



Joined: 28 Sep 2010
Posts: 1

PostPosted: Tue Sep 28, 2010 3:49 pm    Post subject: Trying to upgrade Reply with quote

I need to build an email parser, and from what I can read, I need to update PEAR. I was able to get to version 1.3.3, but can't get any further.

Please don't judge... I inherited this system, and the owner won't let me upgrade (other than PEAR).

Output to pear -V

PEAR Version: 1.3.3
PHP Version: 5.0.4
Zend Engine Version: 2.0.4-dev
Running on: Linux myserver.net 2.6.17-1.2142_FC4smp #1 SMP Tue Jul 11 22:57:02 EDT 2006 i686

When I run:
pear upgrade --force http://pear.php.net/get/PEAR-1.4.3

I get:
downloading PEAR-1.4.3.tgz ...
Starting to download PEAR-1.4.3.tgz (276,859 bytes)
.........................done: 276,859 bytes
requires package `Archive_Tar' >= 1.3.1
PEAR: Dependencies failed


I also get:
PEAR_Remote: unexpected HTTP response
with just about any command I run.

I have been reading other forums for the last 2 days and can't find anything except dead ends. The only solution that I haven't been able to test yet is upgrading PHP (so far I have not been allowed... maybe this will be the day!).

Does anyone have any thoughts.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    PEAR Forum Forum Index -> PEAR All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



PEAR Forum topic RSS feed 
Powered by phpBB © 2001, 2005 phpBB Group

Provided by Ministry of Web developement