PEAR Forum :: PHP Extension and Application Repository

PEAR Forum Forum Index
 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
PEAR installer issue, question

 
Post new topic   Reply to topic    PEAR Forum Forum Index -> PEAR
View previous topic :: View next topic  
Author Message
arozar



Joined: 24 Sep 2009
Posts: 1

PostPosted: Thu Sep 24, 2009 3:31 pm    Post subject: PEAR installer issue, question Reply with quote

Im using Scientific Linux, trying to setup a SNORT box, and have goten to the point that I need to run;

pear install Image_Color, it worked great.

pear install Image_Canvas-alpha, not so much

this is the output
pear/Image_Canvas requires PEAR Installer (version >= 1.8.1), installed version is 1.4.9
No valid packages found
install failed

this is what I get as my version
pear version
PEAR Version: 1.4.9
PHP Version: 5.1.6
Zend Engine Version: 2.1.0

so i run this
pear upgrade pear
Skipping package "pear/PEAR", already installed as version 1.9.0
No valid packages found
upgrade failed

here is my list of packages
pear list
Installed packages, channel pear.php.net:
=========================================
Package Version State
Archive_Tar 1.3.3 stable
Console_Getopt 1.2.3 stable
Image_Color 1.0.3 stable
PEAR 1.9.0 stable
Structures_Graph 1.0.2 stable
XML_Util 1.2.1 stable


I don't understand, why is my version1.4.9, but PEAR package is 1.9.0. Do I need to run another command to install the package?
Back to top
View user's profile Send private message
vbundi



Joined: 14 Jan 2010
Posts: 1

PostPosted: Thu Jan 14, 2010 7:04 pm    Post subject: bump Reply with quote

Sorry to bump an old topic but I also having this problem.

Running centos 5.4
Back to top
View user's profile Send private message
uvstudios



Joined: 15 Jan 2010
Posts: 1

PostPosted: Fri Jan 15, 2010 11:10 pm    Post subject: Reply with quote

I'm having the same problem here. I even downloaded the tar file and tried to install it, but i am not able to make the install. I'm not sure what is going on here. If i figure out anything i'll post back to let you know.

Okay i figured it out this is what you need to do. You are going to need to force the upgrade so type this into your shell.

Code:
 pear upgrade --force PEAR-1.9.0


That should fix all the problems you are having.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    PEAR Forum Forum Index -> PEAR All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



PEAR Forum topic RSS feed 
Powered by phpBB © 2001, 2005 phpBB Group

Provided by Ministry of Web developement