PEAR Forum :: PHP Extension and Application Repository

PEAR Forum Forum Index
 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
image not show on hosting

 
Post new topic   Reply to topic    PEAR Forum Forum Index -> Text
View previous topic :: View next topic  
Author Message
kidkae



Joined: 08 May 2009
Posts: 5

PostPosted: Fri May 08, 2009 6:46 pm    Post subject: image not show on hosting Reply with quote

i do some captcha on localhost using xampp
it look fine, the captcha image was seen

but when i'm upload it on a hosting
it show some error like this:

Fatal error: Class 'Text_CAPTCHA' not found in /home....

on PEAR cpanel, i have instal text_captcha and image_text
is there anything have to be configured on captcha after put it on the server?

thanks
Back to top
View user's profile Send private message Yahoo Messenger
mark



Joined: 07 Jan 2007
Posts: 1235

PostPosted: Sat May 09, 2009 11:16 am    Post subject: Reply with quote

Either you haven't included the Text/Captcha.php file not correctly or the include_path isn't set correctly.
Back to top
View user's profile Send private message
kidkae



Joined: 08 May 2009
Posts: 5

PostPosted: Mon May 11, 2009 10:18 am    Post subject: Reply with quote

this is my include path

ini_set('include_path' , ini_get('include_path')
. PATH_SEPARATOR . '../include/');

could have something wrong on that?
coz i do the captcha fine on localhost using the latest xampp (1.7.1)

thanks mark
Back to top
View user's profile Send private message Yahoo Messenger
mark



Joined: 07 Jan 2007
Posts: 1235

PostPosted: Mon May 11, 2009 10:32 am    Post subject: Reply with quote

Instead of '../include', I'd try to use an absolute path.
Back to top
View user's profile Send private message
kidkae



Joined: 08 May 2009
Posts: 5

PostPosted: Mon May 11, 2009 12:03 pm    Post subject: Reply with quote

humm...

but i need that '../include' path so it can work with the other code

to get the captcha work, could it possible if i put manual captcha and image_text folder inside the '../include', so that i do not have to change my include path?

thanks mark
Back to top
View user's profile Send private message Yahoo Messenger
mark



Joined: 07 Jan 2007
Posts: 1235

PostPosted: Mon May 11, 2009 1:50 pm    Post subject: Reply with quote

kidkae wrote:
but i need that '../include' path so it can work with the other code


Hmm, how should an absolute path be a problem here?

But if it really is, you can also append the absolute path to the current include_path.

kidkae wrote:
to get the captcha work, could it possible if i put manual captcha and image_text folder inside the '../include', so that i do not have to change my include path?


Yes, as long as the directory structure is right, i.e. there needs to be a "Text" and an "Image" folder there. (Maybe this is the problem currently?)
Back to top
View user's profile Send private message
kidkae



Joined: 08 May 2009
Posts: 5

PostPosted: Tue May 12, 2009 9:43 pm    Post subject: Reply with quote

i have put Text and Image folder in '../include'
but now i've got this eror :

Warning: require_once(PEAR.php) [function.require-once]: failed to open stream: No such file ............./include/Text/CAPTCHA.php on line 22

Fatal error: require_once() [function.require]: Failed opening required 'PEAR.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:../include/') in .............../include/Text/CAPTCHA.php on line 22

its call the PEAR.php
i do think now the include_path maybe is the problem.
now i'm still learn and try how to use the ini_set correctly so it can work find with the captcha and other code.
do you maybe have some suggestion for me?

thanks mark
Back to top
View user's profile Send private message Yahoo Messenger
mark



Joined: 07 Jan 2007
Posts: 1235

PostPosted: Tue May 12, 2009 10:21 pm    Post subject: Reply with quote

PEAR.php needs to be in the directory in which the "Image" and "Text" directories reside.
Back to top
View user's profile Send private message
kidkae



Joined: 08 May 2009
Posts: 5

PostPosted: Wed May 13, 2009 2:21 pm    Post subject: Reply with quote

i though it will be much difficult
but it is not..

after i've put PEAR.php
next i've put PEAR5.php
then i've put the text_password and the image_text
and the captcha image shows on the server now
like it work on localhost

thanks for your help mark! Smile
Back to top
View user's profile Send private message Yahoo Messenger
everyone



Joined: 10 Mar 2010
Posts: 1

PostPosted: Wed Mar 10, 2010 12:39 pm    Post subject: Reply with quote

Me too !I have pictures that do not show up. While editing and previewing they show up, but once published they do not show.
_________________
free baby samples
free baby samples
Back to top
View user's profile Send private message
judthryn



Joined: 06 Aug 2010
Posts: 1

PostPosted: Fri Aug 06, 2010 10:35 am    Post subject: Reply with quote

Do you have any idea whether it may need a image hosting or is just a simple images included in your web page which fails to appear when hosted?
_________________
Managed Service provider
Back to top
View user's profile Send private message
role.ner



Joined: 17 May 2011
Posts: 5

PostPosted: Thu May 19, 2011 12:49 am    Post subject: Reply with quote

I think this has something to do with your path to be set wrong. Or your hosting mixes all the directories up.

You also might want to have a look at the absolute path, and try appending it to the main include path.

I really like captcha but recently I have been getting a lot of complaints how even the human users could not understand the texts. It seems to me that it is getting more complex for even real people to decipher.
Back to top
View user's profile Send private message
hugticz



Joined: 16 Jun 2011
Posts: 1

PostPosted: Thu Jun 16, 2011 12:20 pm    Post subject: Reply with quote

Hey try this <img src="images/image1.jpg" width="685" height="52" align="bottom">

doesn't work when image1.jpg is in images folder.

but when I change it to:

<img src="image1.jpg" width="685" height="52" align="bottom">

and put the image in the root directory it works
_________________
How do you get a Medical Marijuana Card
Back to top
View user's profile Send private message
The Mask



Joined: 07 Jul 2011
Posts: 1

PostPosted: Thu Jul 07, 2011 10:31 am    Post subject: Reply with quote

Some of the small coding might have gone wrong.
_________________
Translation Service | Interpreting Services
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    PEAR Forum Forum Index -> Text All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



PEAR Forum topic RSS feed 
Powered by phpBB © 2001, 2005 phpBB Group

Provided by Ministry of Web developement