PEAR Forum :: PHP Extension and Application Repository

PEAR Forum Forum Index
 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
Failed opening required PEAR_Error.php

Post new topic   Reply to topic    PEAR Forum Forum Index -> Installation, Upgrading & Configuration
View previous topic :: View next topic  
Author Message

Joined: 16 Apr 2011
Posts: 1

PostPosted: Sat Apr 16, 2011 11:43 am    Post subject: Failed opening required PEAR_Error.php Reply with quote

Hi, i'm new in this sorry and my english is not very well. I'm having problems migrating my prestashop website. I use CentOS 5. Prestashop uses php and when i tip i receive a blank page. Apache log this error:

Warning: require_once(/var/www/vhosts/ [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/ on line 18

Fatal error: require_once() [function.require]: Failed opening required '/var/www/vhosts/' (include_path='.:/usr/share/pear') in /var/www/vhosts/ on line 18

The problem is that prestashop is not using any PEAR_Error.php file. I mean, that file doesn't exists in prestashop and i think i've read that is deprecated. PEAR_Error class is defined in PEAR.php, which is accesible.

I checked pear in both machines with "pear config-show" and "pear list" and are similar.

Pear test fails:

require_once 'System.php';
var_dump(class_exists('System', false));

so i've tried to add /usr/shar/pear and /usr/shar/pear/ (note last "/") into include_path into php.ini file. The test still fails. then i've tried to add the same into open_basedir directive into virtual host configuration. Then the response is:


but still i got a blank page....!!

this is my "pear version" output:

PEAR Version: 1.4.9
PHP Version: 5.1.6
Zend Engine Version: 2.1.0
Running on: Linux.....

In my old host, website runs ok with same versions and, the most rare, i've tried pear test (for the first time) into this old host and test fails! but the website is working from about one year!

Has anybody some idea? i would be grateful! now i'm getting insane Smile

ah, also y tried to put 777 permissions into all httdocs directory

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    PEAR Forum Forum Index -> Installation, Upgrading & Configuration All times are GMT + 2 Hours
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

PEAR Forum topic RSS feed 
Powered by phpBB © 2001, 2005 phpBB Group

Provided by Ministry of Web developement