PEAR Forum :: PHP Extension and Application Repository

PEAR Forum Forum Index
 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
Upgrading from PEAR 1.3.2

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    PEAR Forum Forum Index -> General PEAR questions
View previous topic :: View next topic  
Author Message
zunit



Joined: 02 Dec 2007
Posts: 1

PostPosted: Sun Dec 02, 2007 1:23 pm    Post subject: Upgrading from PEAR 1.3.2 Reply with quote

Hi there,

I cant seem to find a solution to this issue so I am hoping somebody might be able to help.

I am trying to upgrade PEAR from the ancient version of 1.3.2 on our server to a more recent version so I can begin to use pear for future developments. However I always seem to run into some problem of some sort.

The upgrade command "pear upgrade PEAR" fails to upgrade and outputing the following message:

----------------------------------------------------------------

downloading PEAR-1.6.2.tgz ...
Starting to download PEAR-1.6.2.tgz (297,794 bytes)
..........................................................done: 297,794 bytes
requires package `PEAR' >= 1.3.3
requires package `Structures_Graph' >= 1.0.2
PEAR: Dependencies failed

---------------------------------------------------------------

I have searched the net for a possible solution but I seem to run into similar problems applying the solutions I have found so far. A suggested solution from http://pear.php.net/news/package.xml.1.0.php was to do the following but that didnt seem to help either:

pear upgrade --force PEAR-1.3.6 Archive_Tar-1.3.1 Console_Getopt-1.2
pear upgrade PEAR-1.4.3
pear upgrade --force PEAR-1.4.11
pear upgrade PEAR

Any help will be much appreciated.

Cheers.
Back to top
View user's profile Send private message
mark



Joined: 07 Jan 2007
Posts: 1235

PostPosted: Sun Dec 02, 2007 2:05 pm    Post subject: Reply with quote

The quoted four commands from the PEAR website should help you. If they didn't, you might to provide the error messages, as otherwise we could only guess why they failed for you.
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    PEAR Forum Forum Index -> General PEAR questions All times are GMT + 2 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



PEAR Forum topic RSS feed 
Powered by phpBB © 2001, 2005 phpBB Group

Provided by Ministry of Web developement